Dr.Sum Connect Ver.5.0、5.1 アダプタ接続の対応バージョンについて

製品ブランド:

Dr.Sum

公開日時:

2018/02/28 09:00

更新日時:

2022/06/28 10:00

記事番号:

000015701

Dr.Sum Connect Ver.5.0、5.1 アダプタ接続先製品の対応状況、注意点について記載しています。
このページの内容は随時更新されますのであらかじめご了承ください。
OS、接続先データソース、ドライバ、JDK(JDBC を使用する場合)のバージョンは、Dr.Sum EA関連製品のみならず、相互にサポートされている必要があります。
運用環境をご確認のうえ、各ベンダーのサポート状況をご確認ください。

また、JDBC アダプタ、ODBC アダプタ、SQL Server アダプタ(ODBC接続) のサポートポリシーに関しましては、以下のページをご参照ください。
Dr.Sum EA Connect ODBC/JDBC 製品の販売終了に伴う製品構成変更について
→ODBCおよびJDBCアダプタの今後のサポート対応について

利用のための準備については、インストールガイドの「11. アダプタの事前設定」内の対象アダプターの情報を参照してください。
また、利用における制限事項や注意事項に関しては、Dataspider Studio のヘルプメニューから、「アダプタ」内にある各アダプタの情報を参照してください。

※更新日時点での接続対象のアダプタ製品一覧は以下のとおりです。

 

  接続先アダプタ名 接続先製品のバージョン 備考
■データベース
  IBM DB2
(for Windows、AIX、Solaris)
V9.1/V9.5/V9.7/V10.1/V10.5/V11.1
  • 接続方式はJDBC接続となります。Type4の接続形式をサポートします。
  • 各バージョンに対応したJDBCドライバーが必要となります。
  • Net接続の場合はDB2側にサービスを起動する必要があります。
  • for IBM System i は「 IBM DB2 UDB [IBM System i]」欄を参照してください。
IBM DB2 UDB [IBM System i] V7R1/V7R2/V7R3/V7R4※11
  • 接続方式はJDBC接続となります。
  • 各バージョンに対応したJDBCドライバーが必要となります。
MySQL 5.0/5.1/5.5/5.6/5.7
  • 接続方式はJDBC接続となります。
  • 各バージョンに対応したJDBCドライバーが必要となります
  • Amazon RDS DBインスタンスへの接続はサポートしていません。
    Amazon RDS DBインスタンスへ接続する場合は、Amazon RDS for MySQLアダプタを使用してください。
  • Amazon Aurora への接続はサポートしていません。
    Amazon Aurora へ接続する場合は、Amazon Aurora for MySQLアダプタを使用してください。
Oracle Database JDBC Thin接続
9iR1/9iR2/10gR1/10gR2/
11gR1/11gR2/12cR1/12cR2※5※6 / 18c※4※7/ 19c※10
  • 接続方式はJDBC接続となります。
  • 各バージョンに対応したJDBCドライバーが必要となります。
  • Amazon RDS DBインスタンスへの接続はサポートしていません。
    Amazon RDS DBインスタンスへ接続する場合は、Amazon RDS for Oracleアダプタを使用してください。
JDBC XA接続
9iR1/9iR2/10gR1/10gR2/
11gR1/11gR2/12cR1/12cR2※5※6 / 18c ※4※7
  • 接続方式はJDBC接続となります。
  • 各バージョンに対応したJDBCドライバーが必要となります。
  • Amazon RDS DBインスタンスへの接続はサポートしていません。
    Amazon RDS DBインスタンスへ接続する場合は、Amazon RDS for Oracleアダプタを使用してください。
OCI 接続
11gR2
  • 接続方式はJDBCドライバーを経由したクライアント接続となります。
  • 各バージョンに対応したJDBCドライバーが必要となります。
  • オラクルクライアントツール「Net Configration」 等でOracle Listenerとの接続が確立されていることを前提とします。
  • Dr.Sum Connect Serverは、64bit OSにのみ対応しているため、Oracleクライアントについても64bit版をインストールしてください。
  • Oracle OCIアダプタを使用するには、以下のクライアントをConnect Server稼働OSにインストールする必要があります
    Oracle Database Client 11gR2(11.2.0)
  • Amazon RDS DBインスタンスへの接続はサポートしていません。
    Amazon RDS DBインスタンスへ接続する場合は、Amazon RDS for Oracleアダプタを使用してください。
PostgreSQL 8.2/8.3/8.4/9.0/9.1/9.2/9.3/9.4/9.5/9.6/10※2/11※8/12※12
  • 接続方式はJDBC接続となります。
  • Amazon RDS DBインスタンスへの接続はサポートしていません。
    Amazon RDS DBインスタンスへ接続する場合は、Amazon RDS for SQL Serverアダプタを使用してください。
Microsoft SQL Server 2005/2008/2008R2/2012/2014/2016/2017※2/2019※11
  • 接続方式はJDBC接続となります。
  • 各バージョンに対応したJDBCドライバーが必要となります。
  • Amazon RDS DBインスタンスへの接続はサポートしていません。
    Amazon RDS DBインスタンスへ接続する場合は、Amazon RDS for SQL Serverアダプタを使用してください。
JDBC  
■ファイル
  CSV  
  • CSV(Comma Separated Values)形式またはTSV(Tab Separated Values)形式のファイルを読み取ります。
  • Java SE Runtime Environment 8.0でサポートされているエンコードを指定することができます。
Microsoft Excel 2007/2010/2013/2016
  • Excel 2007/2016/2013/2010で作成した、Excelブック(拡張子「.xlsx」と「xlsm」)とExcel2003ブックをサポートしています。
  • Excelアダプタの「シートから読み取り」処理にてExcelブック(拡張子「.xlsx」と「xlsm」)のファイルを指定する場合、「セルの数式を読み取る」を設定することはできません。
HTML  
  • HTMLファイルやHTMLデータを生成します。
XML  
  • XML文書にDTDが指定されている場合でも、DTDによる検証(validation)は行われません。
  • BOM(Byte Order Mark)を含んだUTF-8エンコーディングのXMLファイルの読み取りはできません。
  • ファイル出力の場合は、Java SE Runtime Environment 8.0でサポートされているエンコードを指定することができます。
固定長ファイル  
  • Java SE Runtime Environment 8.0でサポートされているエンコードを指定することができます。
可変長ファイル  
  • Java SE Runtime Environment 8.0でサポートされているエンコードを指定することができます。
■アプリケーション
  Dr.Sum Dr.Sum/Dr.Sum EA
4.0/4.0_SP1/4.1/4.2/5.0/5.1※4/5.5※11
 
Dr.Sum DataLoader/Dr.Sum EA DataLoader
4.0/4.0_SP1/4.1/4.2/5.0/5.1※4/5.5※11
 
Dr.Sum Datalizer/Dr.Sum EA Datalizer
4.0/4.0_SP1/4.1/4.2/5.0/5.1※4/5.5※11
  • 次の定義ファイルとは連携できません。
    for Excel クライアントで作成した定義ファイル/集計表マップ/クロスマップ/リンク定義
    ※ただし、Datalizer Expertエディションの場合、またはDatalizer Professional for Excelエディション、Datalizer for Excelエディションを他のエディションと同一環境で使用している場合は、for Excel クライアントで作成した定義ファイル(Ver.4.2の場合はTYPE4定義に限る)も連携可能です。
  • 連携先 Datalizer サーバーは、Expert/Professional for Web/for Webのいずれかのエディションを含む必要があります。
  • Excel Pluginで作成したVer.4.2のTYPE4定義を使用する場合、Webモード実行で集計された結果がダウンロードされます。
IBM Domino・Lotus Domino・HCL Domino 5.0/6.0/6.5/7.0/8.0/8.5/9.0/11.0※13
  • DominoサーバーにDIIOP経由で接続を行います。
  • 以下のサービスが起動していることが前提となります。
     ・DIIOP Server
     ・HTTP Server(HTTP Web Server) 
  • 複数のバージョンを同時に使用することはできません。
  • コンポーネント名を以下のように変更しました。※13
    • IBM Domino アダプタ ⇒ HCL Domino アダプタ
    • IBM Notes アダプタ ⇒ HCL Notes アダプタ
  • HCL Domino 11.0 アダプタを追加しました。※13

  ※本アダプタは、HCL Domino 11.0 および HCL

   Domino 10.0 への接続が可能なアダプタです。

  • HCL Notes 11.0 アダプタを追加しました。※13

  ※本アダプタは、HCL Notes 11.0 および

   HCL Notes 10.0 への接続が可能なアダプタです。

 

Universal Connect/X 8.2/9.0/9.1/9.2※1  
Report Director Enterprise 8.2/9.1/9.2  
■ネットワーク
  FTP FTPサーバ
  • Microsoft FTP Service (Version 5.0)Solaris 8/10にバンドルされているFTPサーバ
  • AIX 5.3にバンドルされているFTPサーバ
  • Red Hat Enterprise Linux 4 ESにインストールされたProFTPD(Version 1.3.1)
 
SFTPサーバ
  • Red Hat Enterprise Linux 4 ESにバンドルされているSSHD上で動作するSFTPサーバ
 
FTP over SSLサーバ
  • Red Hat Enterprise Linux 4 ESにインストールされたProFTPD (version 1.3.1)上で動作するFTP over SSLサーバ
  • Windows Server 2003 Enterprise x64 EditionにインストールされたFileZilla Server(version 0.9.25 beta)上で動作するFTP over SSLサーバ
  • 本アダプタは、RFC 1123に準拠したサーバへの接続を想定しています。RFC 1123に準拠していないサーバへの接続を行った場合には、処理に失敗することがあります。
  • SSHバージョン1には対応していません。
REST    
メール  
  • POP3/IMAP4/SMTPに対応しています。
  • OAuth2.0認証に対応しています。※11
  • Java SE Runtime Environment 8.0でサポートされているエンコードを指定することができます。
■クラウド
  Amazon Web Services Amazon Aurora for MySQL
  • Amazon Aurora MySQL 5.7※4
  • MySQL 5.6 on Amazon Aurora
 
Amazon DynamoDB  
Amazon EC2  
Amazon RDS for MySQL
  • Amazon RDS for MySQL 8.0※4
  • MySQL 5.7 on Amazon RDS
  • MySQL 5.6 on Amazon RDS
  • MySQL 5.1 on Amazon RDS
  • 接続方式はJDBC接続となります。
  • 各バージョンに対応したJDBCドライバーが必要となります。
Amazon RDS for Oracle
  • Amazon RDS for Oracle Database 19c※11
  • Amazon RDS for Oracle Database 12cR2※9
  • Amazon RDS for Oracle Database 12cR1
  • Amazon RDS for Oracle Database 11gR2
  • 接続方式はJDBC接続となります。
  • 各バージョンに対応したJDBCドライバーが必要となります。
Amazon RDS for PostgreSQL
  • Amazon RDS for PostgreSQL 12※13
  • Amazon RDS for PostgreSQL 11※8
  • Amazon RDS for PostgreSQL 10※5
  • PostgreSQL 9.5 on Amazon RDS
  • PostgreSQL 9.4 on Amazon RDS
  • PostgreSQL 9.3 on Amazon RDS 
  • 接続方式はJDBC接続となります。
Amazon RDS for SQL Server
・Amazon RDS for SQL Server 2017※4
・Amazon RDS for SQL Server 2016※5
・Microsoft SQL Server 2014 on Amazon RDS
・Microsoft SQL Server 2012 on Amazon RDS
  • 接続方式はJDBC接続となります。
  • 各バージョンに対応したJDBCドライバーが必要となります。
Amazon RedShift  
Amazon S3  
Amazon SimpleDB  
Amazon SQS  
Microsoft Azure Azure SQL データベース
  • 接続方式はJDBC接続となります。
  • 各バージョンに対応したJDBCドライバーが必要となります。
Azure BLOB ストレージ  
Azure Cosmos DB  
Azure HDInsight  
Azure Machine Learning  
Azure キューストレージ  
Google Apps for Work Gmail
  • OAuth2.0認証に対応しています。※11
Googleドライブ
  • 以下オペレーションを共有ドライブに対応しています。※13
    • ファイル/フォルダー一覧取得処理
    • ファイル/フォルダー読み取り処理
    • ファイル/フォルダー書き込み処理
    • ファイル/フォルダー削除処理
Googleスプレッドシート  
Kintone    
Salesforce Force.com Web Services API Version 23.0/26.0/29.0/34.0/40.0※3/43.0※11
  • Salesforce ライセンスは、Enterprise Edition 以上のライセンスが必要です。
Salesforce Metadata Force.com Web Services API Version  23.0/26.0/29.0/34.0
  • Salesforce ライセンスは、Enterprise Edition 以上のライセンスが必要です。

 

※1 Universal Connect/XアダプタをWindows Server 2012 R2で使用する場合、接続先のUniversal Connect/Xは Ver. 9.2 SP1以降に対応しています。
※2 Dr.Sum Connect 5.0のパッチ 5.0.00.0010(Dataspider Servista 4.1 SP4相当) から対応しています。
※3 Dr.Sum Connect 5.0のパッチ5.0.00.0020(Dataspider Servista 4.1SP5相当)から対応しています。
※4 Dr.Sum Connect 5.1(Dataspider Servista 4.2SP1相当)から対応しています。
※5 Dr.Sum Connect 5.0のパッチ5.0.00.0030(Dataspider Servista 4.1SP6相当)から対応しています。
※6 Dr.Sum Connect 5.0のパッチ0010以降で、Oracle Database Cloud Service(Oracle Database 12c Release 2(12.2))への接続をサポートします。
※7 Dr.Sum Connect 5.1のパッチ0020以降で、Oracle Database Cloud Service(Oracle Database 18c(18.3))への接続をサポートします。
※8 Dr.Sum Connect 5.1のパッチ0020(Dataspider Servista 4.2 SP2相当)から対応しています。
※9 Dr.Sum Connect 5.1のパッチ0030(Dataspider Servista 4.2 SP3相当)から対応しています。
※10 Dr.Sum Connect 5.1のパッチ0040(Dataspider Servista 4.2 SP4相当)から対応しています。
※11 Dr.Sum Connect 5.1のパッチ0060(Dataspider Servista 4.2 SP6相当)から対応しています。
※12 Dr.Sum Connect 5.1のパッチ0070(Dataspider Servista 4.2 SP7相当)から対応しています。
※13 Dr.Sum Connect 5.1のパッチ0080(Dataspider Servista 4.2 SP8相当)から対応しています。


なお、Dr.Sum Connect  には、限定延長保守の対象となるアダプター、および動作保証を行っていないアダプターが同梱されています。

>限定延長保守対象となるアダプターについては以下をご参照ください。
アダプタ接続先 標準保守サービス終了情報​

>動作保証を行っていないアダプターの同梱については以下のとおりです。

  接続先アダプタ名 接続先製品のバージョン 備考
■データベース
  ODBC   データベース専用アダプターが提供されている場合はデータベース専用アダプターを、データベース専用アダプターが提供されていない場合は、JDBCアダプターを使用してください。
※なお、JDBC Proxy Serverと32bitのODBCデータソースの組み合わせでの利用に関しても動作の保証外です。
SQL Server すべてのバージョン ODBC接続のみ動作の保証外です。JDBC接続のグローバルリソースを使用してください。
■アプリケーション
  Dr.Sum Dr.Sum EA
4.1/4.0SP1/4.0/3.0SP3/3.0SP2/3.0SP1/3.0
Dr.Sum 5.0 または Dr.Sum EA 4.2 へのバージョンアップを行ってください。
Dr.Sum EA DataLoader
4.1/4.0SP1/4.0/3.0SP3/3.0SP2
Dr.Sum Datalizer 5.0 または Dr.Sum EA Datalizer 4.2 へのバージョンアップを行ってください。
Dr.Sum EA Datalizer
4.1/4.0SP1/4.0/3.0SP2
Dr.Sum DataLoader 5.0 または Dr.Sum EA DataLoader 4.2 へのバージョンアップを行ってください。

 


 

 

変更履歴
2018/02/28 ・新規公開
2018/08/09 ・Dr.Sum Connect 5.0.00.0010 パッチ公開に伴い、Microsoft SQL Server 2017、PostgreSQL 10 を追加しました。
・Dr.Sum Connect 5.0出荷当初より限定延長保守対象となる以下の製品を追加しました。
 - IBM DB2(for Windows、AIX、Solaris) V9.1/V9.5
  - MySQL 5.0/5.1
  - Oracle 9iR1/9iR1/10g/10gR2/11gR1
  - PostgreSQL 8.2/8.3/8.4/9.0/9.1
  - Microsoft SQL Server 2005
  - IBM Domino・Lotus Domino 5.0/6.0/6.5/7.0/8.0
  - MySQL 5.1 on Amazon RDS
・Universal Connect/X アダプターの注意事項にあった不適切な「各バージョンに対応した「UCXSingle.jar」が必要です。」を削除しました。
2018/12/10 ・Dr.Sum Connect 5.0.00.0020 パッチ公開に伴い、Salesforce アダプターにForce.com Web Services API Version 40.0を追加しました。
2019/02/06 ・Dr.Sum Connect 5.0.00.0030 パッチ公開に伴い、以下のアダプターを追加しました。
  - Amazon RDS for SQL Server 2016
  - Amazon RDS for PostgreSQL 10
2019/04/15 ・Dr.Sum Connect Ver.5.1のリリースに伴い、以下のアダプターを追加しました。
 - Dr.Sum 5.1/Dr.Sum DataLoader 5.1/Dr.Sum Datalizer 5.1
 - Amazon Aurora MySQL 5.7
 - Amazon RDS for MySQL 8.0
 - Amazon RDS for SQL Server 2017
2019/05/22 ・注釈※5の付与が漏れていたため追加しました。
2019/08/19 ・Oracle 18cへの対応状況の記載が漏れていたため追加しました。
2019/09/04 ・Dr.Sum Connect 5.1.00.0020パッチのリリースに伴い、次の動作環境を追加しました。
 - Oracle 18c アダプタを使用したOracle Database Cloud Service(Oracle Database 18c(18.3))への接続
 - Amazon RDS for PostgreSQL 11
・Oracle 12cアダプタを使用したOracle Database Cloud Service(Oracle Database 12c Release 2(12.2))への接続について記載が不足していたため追加しました。

2019/11/05

・Dr.Sum Connect 5.1.00.0030パッチのリリースに伴い、以下のアダプターを追加しました。
 - Amazon RDS for Oracle 12cR2
2020/02/03 ・Dr.Sum Connect 5.1.00.0040パッチのリリースに伴い、以下のアダプターを追加しました。
 - Oracle 19c
2020/06/01 ・SQL Server 2019への対応状況に誤りがあったため削除しました。
2020/07/03 ・Dr.Sum Connect 5.1.00.0040パッチのリリースに伴い、以下のアダプターを追加しました。
 - Dr.Sum 5.5
 - Microsft SQL Server 2019
 - IBM DB2 UDB [IBM System i] V7R4
 - Amazon RDS for Oracle Database 19c
  Salesforce アダプター SOAP API バージョン 43.0
・Dr.Sum Connect 5.1.00.0040パッチのリリースに伴い、メールアダプターおよびGmailアダプターにOAuth 2.0の対応状況を追加しました。
2020/07/13 Dr.Sum Datalizer の備考をリライトしました。
2020/11/02

・Dr.Sum Connect 5.1.00.0070パッチのリリースに伴い、以下のアダプターを追加しました。

 - PostgreSQL 12

2020/12/25

・アプリケーションの「Dr.Sum」に以下を追加しました。

 Dr.Sum EA : Ver. 4.0 / 4.0_SP1 / 4.1

 Dr.Sum EA DataLoader: Ver. 4.0 / 4.0_SP1 / 4.1

 Dr.Sum EA Datalizer: Ver. 4.0 / 4.0_SP1 / 4.1

2021/03/04

・Dr.Sum Connect 5.1.00.0080パッチのリリースに伴い、以下のアダプターを追加、更新しました。

 - Googleドライブ: 共有ドライブ(オペレーション指定あり)

 - Amazon Web Services : Amazon RDS for PostgreSQL 12 アダプター

 - IBM Domino・Lotus Domino・HCL Domino: HCL Domino 11.0 アダプター および HCL Notes 11.0 アダプター

2021/03/08

・以下のアダプターのサポート終了日と対象のバージョンを更新しました。

 - クラウド:Salesforce> Force.com Web Services API Version 7.0/14.0/18.0(SalesForce Bulkアダプタ含む)

2021/07/01

以下のアダプターのサポート終了に伴いバージョンを更新しました。

 - クラウド:Salesforce> Force.com Web Services API Version 7.0/14.0/18.0(SalesForce Bulkアダプタ含む):サポート終了日:2021/06/30

2022/03/16 ・「データベース」のOracle Database>10gの表記を10gR1に更新しました。
2022/06/28 ・アプリケーションの「Dr.Sum」の注記を更新しました。