Dr.Sum Connect Ver. 5.1から5.6へのリリース情報
製品ブランド:

Dr.Sum

製品名: Dr.Sum Connect
バージョン: 5.6
公開日時:2021/09/22 09:00
更新日時:2021/09/22 09:00
記事番号:000021997
Dr.Sum Connect Ver. 5.1から5.6へのリリース情報
製品ブランド:

Dr.Sum

製品名: Dr.Sum Connect
バージョン: 5.6
公開日時:2021/09/22 09:00
更新日時:2021/09/22 09:00
記事番号:000021997

Dr.Sum Connect Ver. 5.6の主な変更点を記載します。なお、Ver. 5.1にパッチ5.1.00.0090を適用した状態からの変更点とします。

機能追加/仕様変更/修正事項

全般

  • 「ServerErrorObserver」機能はDr.Sum Connect Ver. 5.6より廃止となりました。
    詳細については、カスタマーサクセスサイトの「Dr.Sum Connect/SPA ETL Option/SVF EA Connect: ServerErrorObserver機能廃止について」を参照してください。
  • 会社の吸収合併に伴い、各種ドキュメントおよびモジュールに含まれる会社名を株式会社セゾン情報システムズに変更しました。[DSS-27299]
  • DB2 V11.5アダプタを追加しました。[DSS-28330]
    本アダプタは、DB2 V11.5 for Linux, UNIX, and Windowsへの接続が可能なアダプタです。
    詳細については、ヘルプを参照してください。
  • リポジトリ DBとして、DB2 V11.5 for Linux, UNIX, and Windowsに対応しました。[DSS-28330]
    • サポートする JDBCドライバ
      • 必要なライブラリ: db2jcc4.jar
      • ドライババージョン: IBM Data Server Driver for JDBC and SQLJ (V11.5用)
  • 同梱している Java Runtime Environment(JRE) を「AdoptOpenJDK 1.8.0_265-b01」に変更しました。[DSS-28329]
  • 製品ロゴを変更しました。[DSS-28721]
  • ライセンスファイルの形式を変更しました。DataSpider Servista 4.3 にバージョンアップする際には、必ずライセンスファイルの再発行が必要となります。[DSS-28327]
    詳細については、「DataSpider Servista 4.3 アップグレードガイド」を参照してください。
  • インストール時の管理者 (root ユーザ) パスワードを入力必須に変更しました。インストールする際には、必ず root ユーザのパスワードを入力してください。[DSS-28321]
  • ヘルプの「パラレルストリーミング処理」ページで、「注意事項」項にPSP データフロー中に条件分岐コンポーネントを配置する場合の注意事項を追加しました。[DSS-27253]
  • 各種ドキュメントで、ソフトウェアサポートサービスのページへの URL を「https://www.hulft.com/support/dss-lifecycle」に変更しました。[DSS-26867]
  • 各種ドキュメントで、販売およびサポートが終了になった以下のコンポーネントのサポート終了に関する記述の追加、または削除を行いました。[DSS-28027/DSS-27860/DSS-27754/DSS-27726/DSS-27048/DSS-27022]
    • プラットフォーム
      • Windows Server 2008 R2
      • Windows Server 2008
      • Windows 7
    • アダプタ
      • MySQL 5.6 アダプタ
      • Oracle 12cR2 アダプタ
      • Oracle 11gR2 アダプタ
      • Oracle OCI アダプタ
      • PostgreSQL 9.5 アダプタ
      • SQL Server 2008 R2 JDBC アダプタ
      • SQL Server 2008 JDBC アダプタ
      • SQL Server 2008 ODBC アダプタ
      • Excel 2010 アダプタ
      • Universal Connect/X 9.1 アダプタ
      • Universal Connect/X 9.0 アダプタ
      • Universal Connect/X 8.2 アダプタ
      • Report Director Enterprise 8.2 アダプタ
      • Amazon RDS for MySQL 5.6 アダプタ
      • Amazon RDS for Oracle 11g R2 アダプタ
      • Amazon RDS for PostgreSQL 9.5 アダプタ
      • Amazon RDS for PostgreSQL 9.4 アダプタ
  • 販売およびサポートが終了になった以下のコンポーネントをインストーラに同梱しないようにしました。[DSS-27367]
    • DB2 V9.5 アダプタ
    • DB2 V9.1 アダプタ
    • SQL Server 2005 JDBC アダプタ
    • SQL Server 2005 ODBC アダプタ
    • Dr.Sum EA 3.0 アダプタ
    • Lotus Domino 7.0 アダプタ
    • Lotus Domino 6.5 アダプタ
    • Lotus Domino 6.0 アダプタ
    • Lotus Domino 5.0 アダプタ
    • Universal Connect/X 9.1 アダプタ
    • Universal Connect/X 9.0 アダプタ
    • Universal Connect/X 8.2 アダプタ
    • Report Director Enterprise 8.2 アダプタ
    • Amazon RDS for MySQL 5.1 アダプタ

DataSpiderServer

  • 同梱している Apache Tomcat のバージョンを「9.0.37」に変更しました。[DSS-28323]
  • XMLログで、「start」要素にコンポーネント種別を示す「component」属性を出力するようにしました。[DSS-27395]
    詳細については、ヘルプの「ログガイド」ページを参照してください。
  • XMLログで、スレッド処理で実行した際に、各要素に実行スレッドの ID を示す「thread」属性を出力するようにしました。[DSS-27395]
    詳細については、ヘルプの「ログガイド」ページを参照してください。
  • ヘルプの「HTTPS設定」ページで、「keytool」コマンドのオプションに関する記述を見直しました。[DSS-27360]
    主な修正点は以下の通りです。
    • 「CAの証明書のインポート」に「-noprompt」オプションを追加
    • 「サーバ証明書のインポート」に「-noprompt」「-trustcacerts」オプションを追加
  • ヘルプの「DataSpiderServerの設定」ページで、「サーバの移行(エクスポート)」項のサーバ移行を使用する際の前提条件に関する記述を修正しました。[DSS-25374]
  • 日付ディレクトリ内に 4GB (4294967295 バイト) 以上のログファイルが存在する場合、ログの圧縮を行うことができず、対象ファイルが含まれる日付ディレクトリが残る問題を修正しました。[DSS-7721]

CLI Console

  • サービスを所有するグループの変更行う「svcchgrp」コマンドを追加しました。[DSS-28642]
    詳細については、CLI Console で「man svcchgrp」および「help svcchgrp」の実行結果を参照してください。
  • サービスのアクセス権限モードの変更行う「svcchmod」コマンドを追加しました。[DSS-28642]
    詳細については、CLI Console で「man svcchmod」および「help svcchmod」の実行結果を参照してください。
  • サービスの所有者の変更行う「svcchown」コマンドを追加しました。[DSS-28642]
    詳細については、CLI Console で「man svcchown」および「help svcchown」の実行結果を参照してください。
  • 共有プロジェクトの権限変更を行う「prochmod」コマンドを追加しました。[DSS-28641]
    詳細については、CLI Console で「man prochmod」および「help prochmod」の実行結果を参照してください。
  • プロジェクトの共有化を行う「proshare」コマンドを追加しました。[DSS-22702]
    詳細については、CLI Console で「man proshare」および「help proshare」の実行結果を参照してください。
  • プロジェクト仕様書の生成を行う「prospecgen」コマンドを追加しました。[DSS-12550]
    詳細については、CLI Console で「man prospecgen」および「help prospecgen」の実行結果を参照してください。
  • スクリプト仕様書の生成を行う「scriptspecgen」コマンドを追加しました。[DSS-12550]
    詳細については、CLI Console で「man scriptspecgen」および「help scriptspecgen」の実行結果を参照してください。

HTTP トリガー

  • [正常終了時の動作] または [異常終了時の動作] で、[別ページへフォワードさせる] を選択した場合、[レスポンス設定/エンコーディング] の設定を有効にするようにしました。[DSS-29018]
    詳細については、「DataSpider Servista 4.3 アップグレードガイド」の「5. バージョンアップに伴う特別な設定」項を参照してください。
  • トリガーで使用しているライブラリ「commons-fileupload」のバージョンを「1.4」に変更しました。[DSS-28294]

DataSpider Studio

  • [スクリプトをサーバから復元] からスクリプトの復元を行った際に、プロジェクトエクスプローラでのスクリプトの並び順が変わる場合がある問題を修正しました。[DSS-10138]
  • 各ビューを移動させて別のビューにドッキングさせた際に、デザイナが操作不能になる場合がある問題を修正しました。[DSS-9131]
  • 以下の条件をすべて満たすと、スクリプトの保存時 server.log に「Mapping compile failed.」エラーが出力され、スクリプトの実行時に Mapper の処理が行われなくなる問題を修正しました。[DSS-28915]
    1. DataSpider Servista 4.1 より前で「CSVファイルによる置換」ロジックを含むスクリプト (プロジェクト) を作成する
    2. 1. のプロジェクトを DataSpider Servista 4.2 SP2 以降で開き、CSVファイルによる置換ロジックを含むスクリプトを開かずに、スクリプト変数の新規作成や既存スクリプト変数の編集を行う
  • スクリプトメニューの [呼び出し元の検索] で、検索時に使用する一時ファイルが削除されずに残り続ける問題を修正しました。[DSS-28912]

コントロールパネル / DataSpiderServerの設定

  • サーバ移行の「DataSpiderServer設定のエクスポート/インポート」で、エクスポートまたはインポートに 290 秒以上かかる場合、強制終了せず、処理を継続するように変更しました。[DSS-25568]

DataSpider Servista ヘルプ

  • サポートウェブブラウザのバージョンを以下のように変更しました。[DSS-28357]
    • Microsoft Edge 87 以降
    • Firefox 83 以降
    • Google Chrome 87 以降
  • 以下のウェブブラウザをサポート終了としました。[DSS-28357]
    • Internet Explorer 10

スクリプトコンポーネント

  • スクリプト呼び出し処理で、DataSpider Studio で操作を行うと [入出力] タブの [入力変数] / [型] の設定値が不正な状態になる場合がある問題を修正しました。[DSS-18172]

Mapper 共通

  • 変数 Mapper を開いている状態(メモリ展開状態)で、XML 型のスクリプト入力変数を作成すると、入力元スキーマに変数名が正しく表示されない問題を修正しました。[DSS-8597]

Multi-Stream Converter

  • 結合処理、集計処理、ソート処理の各オペレーションで、実行に失敗した場合、エラーメッセージにオペレーション名が出力されない問題を修正しました。[DSS-28602]

データベースアダプタ共通

  • 検索系SQL実行処理で、SQLウィザードを使用して [SQL文] の再編集を行うと、プロパティ設定ダイアログのテーブルパラメータの表示が崩れる場合がある問題を修正しました。[DSS-7853]

Oracle アダプタ

  • ヘルプのサポートバージョンごとの「制限事項」ページで、「仕様制限」項にシノニムの操作に関する記述を追加しました。[DSS-26602]

PostgreSQL アダプタ

  • PostgreSQL 13アダプタを追加しました。[DSS-28863]
    本アダプタは、PostgreSQL 13への接続が可能なアダプタです。
    詳細については、ヘルプを参照してください。
  • リポジトリ DBとして、PostgreSQL 13に対応しました。[DSS-28863]
    • サポートする JDBCドライバ
      • 必要なライブラリ: postgresql-42.<バージョン>.jar
      • ドライババージョン: PostgreSQL JDBC 4.2 (<バージョン>)

SQL Server アダプタ

  • ヘルプの「ライブラリのインストール」ページで、「必要なライブラリ」項のライブラリのバージョン表記を 2 桁に変更しました。[DSS-28929]
  • サポートするライブラリのドライババージョンを以下のように変更しました。[DSS-26325]
    • SQL Server 2019 / 2017 / 2016 / 2014 アダプタ
      • 「Microsoft JDBC Driver 8.4 for SQL Server」
    • SQL Server 2012 アダプタ
      • 「Microsoft JDBC Driver 6.2 for SQL Server」
    バージョンの変更により、コンポーネント変数に格納されるエラー内容が変わる場合があります。
  • 既存のグローバルリソースを開き、[接続名] を変更したあとに[Windows統合認証を使用] にチェックを入れると「NullPointerException」エラーが発生し、グローバルリソースの設定内容が消失する問題を修正しました。[DSS-9835]

JDBC アダプタ

  • グローバルリソースの [コネクション設定] タブで、クライアント情報が設定できる機能を追加しました。[DSS-27317]
    • 【プロパティ項目名】
      [クライアント情報プロパティ一覧]
    • 【プロパティの説明】
      クライアントに関する追加情報を指定します。
    • 【設定例】
      PostgreSQL 9.6 に接続する場合、以下の設定を行うと接続先のカラム「Application_name」に値 [<任意>] を送信します。
      • 名前:ApplicationName
      • 値:<任意>
      詳細については、ヘルプの「グローバルリソースのプロパティ」ページを参照してください。

Excel アダプタ

  • シートから読み取り処理、および定義済み範囲から読み取り処理で、以下の条件を満たす Excel ブック内のセルから値を読み込んだ場合、「NumberFormatException」エラーが発生する問題を修正しました。[DSS-12914]
    • 出力結果が文字列である関数が入力されている
    • そのセルの「表示形式」が「日付」もしくは「時刻」に設定されている

固定長・可変長アダプタ共通

  • 固定長ファイル読み取り処理、および可変長ファイル読み取り処理で、実行パフォーマンスが向上しました。[DSS-28551]

ファイル操作アダプタ

  • ZIP解凍処理で、ZIP ファイルのエントリに親フォルダへの参照がある場合、コンポーネントの実行に失敗するように変更しました。[DSS-28837]

Dr.Sum アダプタ

  • Dr.Sum 5.6 アダプタを追加しました。[DSS-29400]
    本アダプタは、Dr.Sum 5.6 および Dr.Sum Datalizer 5.6 への接続が可能なアダプタです。
    詳細については、ヘルプを参照してください。
  • ヘルプの「稼働環境」ページの「サポートバージョン」-「Dr.Sum 5.5アダプタ」項、および「Dr.Sum 5.5アダプタ制限事項」ページで、Dr.Sum Datalizer Professional for Excel に関する注意事項を追加しました。[DSS-28967]

FTP アダプタ

  • コントロールパネルの「グローバルリソースの設定」から存在するグローバルリソースのプロパティを開き、[名前] を変更後 [セキュアFTP設定] タブの [セキュリティタイプ] を変更するとエラーが発生する問題を修正しました。[DSS-7400]

Amazon Web Services アダプタ / Amazon RDS for Oracle アダプタ

  • ヘルプのサポートバージョンごとの「制限事項」ページで、「仕様制限」項にシノニムの操作に関する記述を追加しました。[DSS-26602]

Amazon Web Services アダプタ / Amazon RDS for SQL Server アダプタ

  • Amazon RDS for SQL Server 2019アダプタを追加しました。[DSS-29149]
    本アダプタは、Amazon RDS for SQL Server 2019への接続が可能なアダプタです。
    詳細については、ヘルプを参照してください。
  • リポジトリ DBとして、Amazon RDS for SQL Server 2019に対応しました。[DSS-29149]
    • サポートする JDBCドライバ
      • 必要なライブラリ: mssql-jdbc-8.4.<バージョン>.jre8.jar
      • ドライババージョン: Microsoft JDBC Driver 8.4 for SQL Server
  • ヘルプの「ライブラリのインストール」ページで、「必要なライブラリ」項のライブラリのバージョン表記を 2 桁に変更しました。[DSS-28929]
  • サポートするライブラリのドライババージョンを以下のように変更しました。[DSS-26325]
    • Amazon RDS for SQL Server 2019 / 2016 / 2014 アダプタ
      • 「Microsoft JDBC Driver 8.4 for SQL Server」
    • Amazon RDS for SQL Server 2012 アダプタ
      • 「Microsoft JDBC Driver 6.2 for SQL Server」
    バージョンの変更により、コンポーネント変数に格納されるエラー内容が変わる場合があります。

Amazon Web Services アダプタ / Amazon Redshift アダプタ

  • ヘルプの「ライブラリのインストール」ページで、「必要なライブラリ」項にドライバ依存ライブラリに関する記述を追加しました。[DSS-29087]

Microsoft Azure アダプタ / Azure SQL Database アダプタ

  • ヘルプの「ライブラリのインストール」ページで、「必要なライブラリ」項のライブラリのバージョン表記を 2 桁に変更しました。[DSS-28929]
  • サポートするライブラリのドライババージョンを「Microsoft JDBC Driver 8.4 for SQL Server」に変更しました。[DSS-26325]
    バージョンの変更により、コンポーネント変数に格納されるエラー内容が変わる場合があります。

G Suite アダプタ / Googleスプレッドシートアダプタ

  • シートから読み取り処理で、クライアントの言語が「英語」の際に、[開始/終了条件] タブの [終了条件] の項目名が実行ログに日本語で出力される問題を修正しました。[DSS-28727]

Salesforce アダプタ / Salesforce アダプタ

  • ヘルプで、データを送受信する際のデータ型の形式ルールについて記述した「データ型の形式」ページを追加しました。[DSS-28955]
  • Salesforce API 43.0 アダプタを追加しました。[DSS-28955]
    本アダプタは、Salesforce API 43.0 への接続が可能なアダプタです。
  • REST API を使用してコンテンツバージョン (ContentVersion) にファイルをアップロードまたは更新する「ファイルアップロード処理」を追加しました。[DSS-DSS-28955]
    本オペレーションのファイルサイズ制限は 2GB (ヘッダーを含む) になります。
    詳細については、ヘルプを参照してください。
    ※[接続先] で「API 43.0」のグローバルリソースを選択した場合に使用できます。
  • 以下のオペレーションで、「SOQL(検索条件)の作成」画面の「条件項目の選択」下の列に値を入力・選択すると、条件項目を絞り込むことができるようにしました。[DSS-28955]
    • データ読み取り(クエリー)
    • データ読み取り(親→子リレーション)
    • データ読み取り(子→親リレーション)
  • 以下の条件をすべて満たすグローバルリソースを使用する場合、「You have sent us an Illegal URL or an improperly formatted request」が出力され、Salesforce への接続に失敗する場合がある問題を修正しました。[DSS-28955]
    • API 29.0 以降のグローバルリソースを使用している
    • [必須設定] タブの [送受信時データ圧縮] に [圧縮する] を選択している
    • [必須設定] タブの [OAuthを使用して接続する] にチェックが入っている

Salesforce アダプタ / Salesforce Metadata アダプタ

  • 新規に以下のプラットフォームに対応しました。[DSS-26990]
    • Amazon Linux 2
  • 以下の条件をすべて満たすグローバルリソースを使用する場合、「You have sent us an Illegal URL or an improperly formatted request」が出力され、Salesforce への接続に失敗する場合がある問題を修正しました。[DSS-28955]
    • API 29.0 以降のグローバルリソースを使用している
    • [必須設定] タブの [送受信時データ圧縮] に [圧縮する] を選択している
    • [必須設定] タブの [OAuthを使用して接続する] にチェックが入っている